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Version History

Version Date Description

1.0 3 Feb 2015 Initial version

11 9 Feb 2015 Addition of linked courses and update on next school

1.2 20 Feb 2015 Additional information on academic tracks and grade levels

13 12 Mar 2015 Updated screenshot in section 1.2.1

14 18 Jan 2017 Reviewed and minor updates

15 18 Jan 2018 Updated section 2.2.2. indicating the course description can be
changed by the school

16 26 Feb 2018 General updates throughout the document.
Added section 2.4 Secondary students - information provided re
secondary students’ online course request process.

17 29 Apr 2019 Added hyperlinks to Table of Contents

Confidentiality
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their permission). In consideration of receipt of this document, the recipient agrees to treat this information
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Student View

1.0 Online Student Course Requests

Students can log on to the Student portal and enter course selections for the coming school
year.

Schools define course selections using an Academic Track Type, Academic Tracks and then
group courses by subject area into Track Selections.

Parents/Guardians with family portal access can monitor their child’s selections. Counselors and
administrators can see and approve requests in the School view.

1.1 Preferences and Setup

Pre-planning at the district and school levels prior to using online student course requesting is
essential. Some important areas to consider are:

o Wil the district and/or schools accommodate more than one Academic Track Type and
for what purpose(s)?

¢ \Who will manage the Academic Track Selection Subject Area reference codes? Both the
district and the schools can create their own subject area codes.

o Agreement should be reached as to processes regarding the copying of Academic
Tracks among schools in the district.

¢ Who will manage student and parent/guardian user accounts? This topic is beyond the
scope of Module 5, but must be included in district/school planning for online student
course requests.

e At the school level, decisions will have to be made regarding the assigning of required
courses.

e At the school level, decisions will have to be made regarding the number of maximum
and minimum subject area selections.

e At the school level, decisions will have to be made regarding when to open the online
course selection window, and for which grades.

1.1.1 Online Student Course Request Checklist

Preparing for student online course requests should follow the order of the checklist provided
below.

Build year context set in school details

Course catalogues for next school year complete

Assign students’ Next School

Assign students’ an Academic Track Type; this can only be done for Primary students

o O O O
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o Create or Copy Academic Tracks — School Course Selections Outline
o Build Track Selections — Subject Areas
o Create/distribute/manage student/parent accounts for portal access

In order to enable students’ ability to do online course requests, the build year context must be
set (School View > School > Setup > Details) and the school course catalogue must be
established for the build year (School View > Schedule > Courses, filter for Build Year).

Students will need their Next School assigned and should also have their Academic Track Type
set. This is done in the School View > Student list, using the Pre-transition field set. Both of
these fields can be Mass Updated, and Modify List can also be used.

Note: The Academic Track Type field is not available in a student’s Details screen.

Hugh Boyd Secondary 2016-2017 School View » A Select School  Coltura, Sbneighbourhood v @ Log Off

RIULLL I Staff  Attendance  Conduct  Grades  Assessment  Schedule  Global  Tools  Admin

Student List

Details >
”
Contacts
< || 1:Aaron, Duncandetach Mk 0 of 744 selected &7 Primary Active Students
Attendance = .
Name Pupil # Alerts DOB YOG  Grade GrSublvl EnrStatus School > Name NextSkl> Name AcademicTrack Homer
Conduct Aaron, Duncandetach 1369261 21/08/1999 2017 12 Active Hugh Boyd Secondary Hugh Boyd Secondary Standard 23
Transcript Abasikhalili, Amadullah 553695 B 24/09/1998 2016 12 Active Hugh Boyd Secondary Standard 33C8
Abazi, Catinas 650438 14/01/2000 2018 1 Active Hugh Boyd Secondary Hugh Boyd Secondary Standard 22
Assessments
Abeeke, Caroledave 623310 & 28/12/1999 2017 12 Active Hugh Boyd Secondary ~ Hugh Boyd Secondary  Standard 23
Academics Adubofourpoku, Patriciea 650505 01042003 2021 08 Active Hugh Boyd Secondary 05ING
Schedule Afsmile, Kelitann 2073491 09/10/2002 2020 09 Active Hugh Boyd Secondary Hugh Boyd Secondary 10
Agabas, Laurenetpatrick 1510110 @2 2106(1998 2017 12 Active No Primary  Hugh Boyd Secondary Standard 22
Membership

1.2 Student Portal and Course Requests

Initial setup will be time consuming, however once complete it will carry over from one year to
the next with very little likelihood of modification being necessary.

Logging in to the portal, students will find course requests from My Info > Requests.

Students will find the Instructions block at the top of the entry mode window. Above this is a line
indicating the next school year for which the requests are made, the number of primary and
alternate requests selected, the percent scheduled and the total credits.

Module 5: Online Student Course Requests v1.7 Page 5
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Richmond 2016-2017
Abazi, Catinas

Student View ~ & Select Student  Coltura, Sbneighbourhood v @ Log Off

Academics = Groups  Calendar  Locker

Requests
My Details
’ (oo | ETEETENE Y = 0 =
Transcript <= Exit entry mode M
Current 2017-2018 - Requests: 11 primary, 1 alternate - Scheduled: 79% - Credits: 40.0
Schedule
P setions Gis is from the Details of the Academic Tracks
- - School > Schedule > Academic Track > Details]
Next Year's Grade 12s: Course Selection Options 4¥‘ !
Aftendance
Welcome to your last year of high school! Hopefully you've taken some time, and talked with your parents, around choosing courses that are appropriate. As you choose your courses keep in mind
ELTAE your interests, your personal strengths and your future plans. Your post secondary options may depend on which courses you pick.
Assessments If you would like to select a course the doesn't appear in the lists presented to you please write a note at the bottom to your counselor explaining the situation
Membership If you would like to register for an online course, including Planning, History 12, Recreation and Service or Peer Tutering, click here.
Notifications Primary requests
REULT Subject area SchoolCourse > CrsNo SchoolCourse >Descriptio]  These are Track Selections  |Altemate? Credit
ELL PKG--12ELL3 ELL 3 PACKAGE e SUbJBCt area N 40
Requests (School > Schedule > Academic
Details English Language Arts MEN--12 ENGLISH 12 Track > Track Selections) N 40
. Fine Arts MAF--12 ART FOUNDATIONS 12 N 40
Graduation

1.2.1 Primary Requests

The screenshot below is for a student going into grade 12, within the English Language Arts
Track Selection - which as illustrated below is displayed as ‘Subject area’ to a student.

Subject area English Language Arts
Instructions Below are the English Language Arts options for grade 12 students.
10f 7 selected

Select CourseNumber CourseDescription Academic level Credit Prequisite Status
() AELC-12 AP ENGLISH LITERATURE & COMPOSITION 12 |Regular 4.0
L MEM--12 EMGLISH 12 Regular 40

MCCOM-12 COMMUNICATIONS 12 Regular 40

MWR--12 WRITING 12 Regular 4.0

MCCOM-11 COMMUMICATIONS 11 Regular 4.0

MEM--11 ENGLISH 11 Regular 40 Course

MEM--11THOMN EMGLISH 11 HOMOURS Regular 4.0

4 3
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Students select the course of their choice and click OK.

Subject are:

a English Language Arts

Academic level

Instructions Below are the English Language Arts options for grade 12 students.

Select CourseNumber CourseDescription
AELC-12 AP EMGLISH LITERATURE & COMPQOSITION 12 | Regular
MEN--12 EMGLIZH 12 Regular

Ld MCOM-12 COMMUMICATIONS 12 Regular
MWR--12 WRITING 12 Regular
MCOM-11 COMMUNICATIONS 11 Regular
MEM--11 EMGLISH 11 Regular
MEMN--11HON EMGLIZH 11 HONOURS Regular

4

¥ Cancel

1.2.2 Alternate Requests

Credit

4.0

4.0

4.0

4.0

4.0

4.0

40

10f 7 selected

Prequisite Status

Course

When creating Track Selections (displayed to students as a Subject area), there is an option to

indicate if a request should show as an Alternate:

Current 2017-2018 - Requests: 11 primary, 1 alternate - Scheduled: 79% - Credits: 40.0
Schedule
Contacts Instructions
1 - 1 1
Attendance Next Year's Grade 12s: Course Selection Options
Conduct Welcome to your last year of high school! Hopefully you've taken some time, and talked with your parents, around choosing courses that are appropriate. As you choose
your courses keep in mind your interests, your personal strengths and your future plans. Your post secondary options may depend on which courses you pick.
Assessments
If you would like to selecta course the doesn't appear in the lists presented to you please write a note at the bottom to your counselor explaining the situation.
itz If you would like to register for an online course, including Planning, History 12, Recreation and Service or Peer Tutoring, click here.
Netificaticns -
Primary requests
Requests Subject area SchoolCourse > CrsNo SchoolCourse > Description Alternate? Credit
Requests
ELL PKG-12ELL3 ELL 3 PACKAGE N 40
Details
m English Language Arts MEN-12 ENGLISH 12 N 4.0
Gri .
Progress Alternate requests
Subject area SchoolCourse > CrsNo SchoolCourse > Description Alternate? Credit
m Other MAC-11CS CS: ACCOUNTING 11 Y 40

Notes for counsellor

Last posted time:

Approved time:

Module 5: Online Student Course Requests v1.7
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1.2.3 Notes for Counselor

There is a field for students to include notes for the counsellor. It is recommended that students
be encouraged to speak to a counsellor. This area may be a good means of making a request
to discuss the student’s choices with their counsellor but there is no automated feature to notify
the counsellor. The note is viewable as the student’s requests are reviewed.

Notes for counselor

Post| Last posted time: 02/02/2015 11:00 AM  Approved time

1.2.4 Posting

Once a student has completed their course selections, they should click on the Post button at
the bottom of the window. Note that all selections are automatically saved, but posting will time
stamp the submission.

1.3 Parent Portal

Student contacts who are identified as parents or guardians, who have family portal access
checked in their details, and who have user accounts, will have access to the course selection
window. From Family View > Family > Schedule > Requests, parents will not only be able to
view their child’s course requests but they have the ability to make selections and changes on
behalf of their children in the same way as the student can.

School View Setup

2.0 Academic Tracks

Academic tracks, is the term used in MyEducation BC that refers to the school course selections
outline for online student course requests. This is analogous to the student course request
sheets common in a paper-based course selection process used in many schools.

Terminology used in MyEducation BC online student course requests can be confusing. The
following will help to address this.

e Academic Track Type: Students must be assigned an academic track type for online
course requesting. This is confusing as the field name presented from the Student tt >
Pre-transition field set is called Academic Track and not Academic Track type. Academic
Track Type codes are defined in the reference tables, School view > Admin > Reference
Tables > Academic Track Type > Codes; OR District view > Admin > Data Dictionary >
Reference > Academic Track Type.

Module 5: Online Student Course Requests v1.7 Page 8
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e Academic Tracks: This term refers to the school course selections outline. Schools
should only require one academic track as the outline will encompass each grade, the
instructions as well as the subject areas and courses contained within.

e Track Selections: Track selections are the grade level subject areas and the courses
within each from which students make their selections.

e Subject Areas: It is recommended that subject areas be defined at the district level to be
used by each school. These are created in the reference table > Academic Track
Selection Subject Area.

2.1 Define Academic Tracks — School Course Selections Outline

An academic track defines a set of possible course selections available to a specific group of
students. They are analogous to the colored course selection sheets common in a paper-based
course selection process. Define an academic track and courses that students can or must
complete when assigned to that track.

To define an academic track / Creating the course selections outline
From School View > Schedule > Academic Tracks, go to Options > Add.

Academic tracks can be copied; however, more than one track type would have to exist in order
for this to be useful. To copy an existing track, select the track and click Details. On the Options
menu, click Copy. Type a number to indicate the number of copies of the track that is desired.
Generally, a single academic track should suffice.

The Academic Track page displays:

Hugh Boyd Secondary 2016-2017 School View v A Select School  Coltura, Sbneighbourhood v @ Log Off

Pages School Student Staff Attendance Conduct Grades Assessment QR CLIEW Global Tools  Admin

Academic Tracks :: Hugh Boyd Secondary Course Selections Q
Master u

"
Schedules

Default Template v

Courses

Name * |Hugn Boya secondary Course Selections

Rooms
Type* Standard v

Structure Minimum credit 0.0

Scheduls Maximum credit 40.0

Attributes Secondary student

anly
Rules
Grade Levels

Academic Tracks
» Details

Gradelevel | Instructions StartDate EndDate

Track Selections
Frssmremiae Next Year's Grade 8s: Course Selection Options
Controls
Welcome to Hugh Boyd Secondary Schooll We're sure that in your time at Boyd you will create memories and friendships 01012017 | 30062017
BT that will last a lifetime...and of course learn a thing or two.

e A name is required for the academic track. In the example above, this track is named
Hugh Boyd Secondary Course Selections.
e Type is also a required field. This is the Academic Track Type.

Module 5: Online Student Course Requests v1.7 Page 9
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¢ A minimum and maximum number of credits can be set for students. Users are
cautioned that this applies to all students using online course requests; therefore, the
Minimum should be set at 0.0 to accommodate non-credit courses.
e Click the Secondary student only check box if this selection sheet is for incoming
secondary students only.
e Use the Grade Levels area of the page to include all the grade levels that are part of the
current track. Click Add to add a grade level, and do the following:
o Click the drop-down to select a grade in the grade level column.
o Type the instructions that display for students in that grade level on their
Requests page in the Student Portal.
o Inthe StartDate and EndDate columns, define the date range in which students
in this grade level can use the Student Portal to make their course selections.
These dates control if the Entry Mode is available, as seen in the Student view

Note: The Grade Level selected is for next year’s grade as illustrated in the
preceding screen capture.

Module 5: Online Student Course Requests v1.7 Page 10
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2.2 Track Selections — Subject Areas

Track selections are used to define the subject areas, and courses within each, for a given
grade from which a student is allowed to choose. Subject areas are defined in the Reference
Tables > Academic Track Selection Subject Area > Codes.

Schools may wish to determine the order in which subject area selections appear in the student
request window. By default, codes are displayed in the portal alphabetically and all have a
sequence number of 0. School users can define the order of appearance by determining the
sequence number of each code. This is set from within the details of each code or can be set
from the Codes view in the default field set shown below. The SeqNo field can be set using
Modify List. A sequence number value of zero is the highest.

Hugh Boyd Secondary 2017-2018 School view v & Select school

Pages School  Student ' Staff @ Attendance Conduct Grades Assessment Schedule Global Tools

Reference Tables :: Academic Track Selection Subject Area

Reference

» Codes
Fields RCCT  ListView ==  Categories Only

0 of 18 selected (7

Comments

Code D ipti Disabled Owner Category Category?

Licenses
Business N Richmond (District) N

Logs ‘ Design N Hugh Boyd Secondary (School) N
Electives N Richmond (District) N

ELL N Richmaond (District) N

2.2.1 To define track selections/subject areas:

From School View > Schedule > Academic Tracks, select the academic track. Then click on the
Track Selections side tab > Options > Add.

From the new academic track selection page:

e Select the grade level for this track selection/subject area, required.

e Set a sequence number here or from the field set to change the order of the subject area
selections.

e Use the drop-down list to select the subject area.

¢ Name can be the same as the subject area

e Determine the maximum and minimum selections students can make in this subject
area.

e For Alternate Requests, the lower block found on the student course request entry
screen, check Alternate only.

e Force Recommendations — leave blank

Module 5: Online Student Course Requests v1.7 Page 11
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Allow direct alternates is useful for non-academic selections where students have a lot of
choice. For example, in Fine Arts if the student doesn’t get Dance, then choose Drama
as a direct alternate choice.

Complete the instructions field for this subject area. The text editor allows for many
presentation options.

Academic Tracks :: Hugh Boyd Secondary Course Selections :: New Academic Track Selection

Master
Schedules
Courses.
Rooms
Structure

Schedule
Attributes

Rules

Academic Tracks
Detail

s
= Track Selections

Recommendation
Controls.

Preferences

®
B save m Default Template
Type
Grade level * Q
Sequence number 0 Alternate only
Subject area Force recommendsation
Name Allow direct alternates
Mazimum selection* [0
Minimum selection * [0

FEOR == E=zz==

Fent - Size - Format A DB
Instructions

4

Course Selections
SeqNo CourseNumber CourseDescription Required? Default? NeedApproval?

LinkedCourseNumbers

o matehing records

B Add Multi-Add... m
T e

Module 5: Online Student Course Requests v1.7
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2.2.2 Course Selections
The lower block of the track selection page is where the user adds the courses to the track
selection/subject area.

Clicking on Multi-Add and selecting the Department field; then using Control-F to query for the
given department, allows for a much quicker means of choosing the courses.

1.A2DP-120DPB AP 2-DDES || = D of 315 selected &7
CrsNo Description Department
AZDP-1ZDPB AP 2-D DESIGN PORTFOLIO 12 Fine Arts
ACAL-1Z AP CALCULUS AB 12 Mathematics
AELC-12 AP EMGLISH LITERATURE & COMPOSITION 12 English
IMYP-10 GRADE 10 PERSOMAL PRCJECT Applied Skills
MAC--11C5 G5 ACCOUNTING 11 Applied Skills
MADFSOEIE DESIGN: HOME ECONOMICS & Applied Skills
MADFSOBIBFY  DESIGM: HOME ECOMOMICS 8 Applied Skills
MADFSOSIB DESIGN: FOODS AMD MUTRITION & Applied Skills
MADGEDEIB DESIGN: TECH ED & Applied Skills
MADGEDSIB DESIGN: ENGINEERING & Applied Skills

13
m ® Cancel
Users can re-order the selection of courses by dragging and dropping from the “stack” icon

next to the sequence number.

Course Selections

SeqNo CourseNumber CourseDescription Required? Default? NeedApproval? LinkedCourseNumbers
10 ACAL-12 AP CALCULUS AB 12 M M N

AZDP-12DPB AP 2-D DESIGN PORTFOLIO 12 M M N

MFOM-12 FOUNDATIONS OF MATHEMATICS 12 M M N
40 MPREC12 PRE-CALCULUS 12 M M N

MPREC11 PRE-CALCULUS 11 M M N

Clicking on the hyperlinked SegNo enables editing of the course record. Users are presented
with the following editable fields:

Course Selections

SeqNo CourseNumber CourseDescription Required? Default? NeedApproval? LinkedCourseNumbers

m ACAL-1Z AP CALCULUS AB 12

e SegNo: This can be changed to re-order the presented list of courses.

e Course Number Do NOT change these here as it will break the link to the courses in
the catalogue and a blue exclamation mark will appear next to the course code as a
result. It is recommended to delete the unwanted course and select the correct one
rather than changing a code and/or name.

e Course Description: This description can be changed by the school. It will then display
in the Student view when a course is being chosen. This does not change the school
course description.

Module 5: Online Student Course Requests v1.7 Page 13
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Required: This is checked if the course is required, displaying for the student but not
allowing any changes to be made.

Default: Check this setting to designate the current course to be selected by default;
however, the student can change this request if they wish.

NeedApproval: This is just a flag that indicates to the student that they need approval
from a counselor; it does not stop them from requesting the course.
LinkedCourseNumbers: This very powerful feature allows the user to link courses
when requesting one of a pair (or more). In the LinkedCourseNumbers field, type the
code of the course or courses to be linked using a comma to separate when more than
one course is linked. For example, students who request MAT--12 Automotive
Technology 12 must also take MAST-2A Automotive Service Technician 12. When the

latter is linked to the former, a request for one automatically assigns both requests.

2.3 Copy Academic Tracks and Track Selections

If a school has created an academic track that would be helpful to share within the district, a
copy can be made and pushed to other schools. Schools can also pull other school’s tracks.

It is recommended that the copying of academic tracks be done at the district level as this can
be either a push or pull option. It is worth noting that when using this feature, both the academic
tracks selected and the accompanying track selections are also copied. This will allow districts

to set up one school and then copy the setup to other schools.

2.3.1 To copy academic tracks between schools:

From School View > Schedule > Academic Tracks go to Options > Copy. The Copy Academic

Tracks dialog box appears.

Copy Academic Track - Google Ch SHRCEN X
W, Copy Aca emic Trac oogle Chrome

(D 192.168.125.10:8082/aspen/copyAcademicTrack.do?deploymentld=aspen &
Copy Mode Push »
Destination Schoolis) | Q
0 of 1 selected &7

Name Type

Hugh Boyd Secondary Course Selections Standard

Exclude courses missing from school course catalog

o3 =

e Copy Mode allows for the push or pull of academic tracks

-

¢ Destination/Source School(s) gives the user the ability to select multiple schools in the

district.
¢ The Name block identifies available academic tracks.

Module 5: Online Student Course Requests v1.7
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e Be sure to check Exclude courses missing from school course catalog to avoid copying
courses that may not exist or wish to be offered at the selected school(s).

Note: When copying Academic Tracks, schools acquiring copies must review all areas of
academic tracks to ensure that they meet the school’s requirements.

2.4 Secondary Students

The following information provides the functionality and necessary setup to enable secondary students to
do online request AT their home school FOR their secondary school. The two schools will need to work
together, to ensure that the setup and timing of the setups match.

NOTE: Only secondary students from within a district can complete online requests.

Overview of which school must complete which components of the setup.
Secondary school:
o Defines an Academic Track Type Name.
NOTE: The name of this must match the name at the Primary school.
e Creates an Academic Track defined as Secondary student only
e Assigns the Academic Track Type to student.
e Creates the Track Selections.
e Can create a secondary association for next year.
NOTE: If a current year secondary association exists, for this school, it must be end dated prior to
creating the new one.

Primary school:
o Defines an Academic Track Type Name.

NOTE: The name of this must match the name at the secondary school.

o Defines (controls) the dates a student can choose courses at their secondary school.

e Can create a secondary association for next year.
NOTE: If a current year secondary association exists, for the same school that this association is
being created for, that must be end dated prior to creating the new one.

Module 5: Online Student Course Requests v1.7 Page 15



