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1.0  Attendance  
 

1.1 Overview of Class Attendance in the Class Office Side Tab 
If a Daily Attendance record exists the values can be “pushed out” to all the classes. In the 
Daily Code column, there will be a Daily Attendance value, followed by two “greater than"  
symbols, like so: >>. Click that symbol and it will copy the A-E code to each of the student’s 
classes. This value will push out to all course sections scheduled that day. If the absence is for 
a portion of the day only, adjust the class attendance by period as needed.  
When the teacher logs in, the teacher will see this value and know that the student has been 

marked absent for that section. 

Class Attendance can also be entered for an individual by clicking on the ellipsis in the 

appropriate period column, bringing up a popup. An attendance code and reason can be 

entered for that class only. 
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Any changes you make in this screen will be visible to the teacher when they go to their Staff 

view > Attendance for this course section 

1.2   Attendance – Class Office side tab 

1. School view > Attendance top tab > Class Office side tab 
a. Use the Class Office side tab exclusively to enter attendance. 
b. This section will only cover Class Office attendance in an elementary 

school with a Twice Daily Attendance set up (AM and PM) 
2. Office staff taking attendance can view and take attendance from the Class 

Office side tab under the Attendance top tab. From here, the filters are very 
important, as they will save a lot of time finding students, and working with the 
existing records.  

3. The Class Office side tab displays both the Daily Code value (if it exists) as well 
as the individual periods that exist in your school structure where you can add or 
edit attendance for each period (AM, PM, 1, 2, 3, etc.)  

a. The Daily Code column represents attendance records created in the 
office. 

b. The Period (AM, PM, 1, 2, 3, etc.) represents attendance records 
generated by teachers in the classroom. (these entries are generally not 
edited in the office in a school that takes twice daily attendance; only in "course-based" 
schools) 

Office Teachers 
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1.2.1   Class Office Filters 

The default filter will be All Records. This will show you every student in the school, 

regardless whether they have an existing attendance record or not. This is useful when 

you will be adding a new attendance record for a student on the given day. If you are 

looking to filter the list to only students that already have Attendance records assigned, 

you will use one of the other filters.  

The Attendance Activity filter will narrow the list of students to those who have any 

attendance records assigned to them on the given date, regardless of whether they are 

Daily Attendance or Class Attendance records. This filter is useful when you want to 

work with only the Attendance Records for a day; perhaps to modify existing ones or to 

remove the record for a student.  

The Attendance Discrepancy filter will display all students who have a Daily 

Attendance value of Absent, but have no Absent records for any of their classes. As 

soon as a student has a single Absent record assigned to one of their classes, they will 

no longer appear in this filter. That is, it does not consider that they may have an Absent 

Portion value of 1.0 but have only been marked as missing one class. 

 

 

1.2.2   Taking Class Attendance in the Class Office side tab 

 

1. If a teacher has Posted attendance for his or her class, the value will appear in 

the AM or the PM column.  

2. To take Class Attendance from this view, 

click on the ellipsis in the Daily Code 

column in the appropriate Student. This 

will open a popup, and you can then 

assign the attendance codes and 

reasons for the student in that class.  

3. If it is an all-day absence, there must be 

a Portion absent = 1, AM code (Absent 

Excused – AE) and Reason, and a PM 

(Absent Excused – AE) code and 

Reason.    

4. Always check to ensure the date is 

correct. 

5. The period attendance must be modified 

to reflect the correct portion absent if 

necessary. 
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1.2.3   Entering a Late Record from the Office (Class Office)  

Attendance top tab > Class Office side tab >  = All Records 
  
To enter a student Late in the Class Office side tab, you must enter a time in order to 
Save the record: 
 

1. Click the ellipses ( ) in the row beside the student's 
name.  A window will open to allow the 
creation of the Attendance record.  

2. Ensure the student's name is correct. 
3. Verify the correct date. 
4. Check the box beside Late 
5. Below the Arrivals & Departures area of 

the screen, click Add. 
6. Select Arrival for the Type. 
7. Enter a Time for the "Late" arrival (required). 
8. Click the box beside "Is excused?" if relevant. 
9. Click OK 

10. ** The  does not work to push a Late or L 
entry out to the AM or Period field.  You must 

also click the ellipses ( ) in the AM column or the correct Period field and 
select L from the pop-up in order for the teacher to see this value. This is an 
important step in the "process" around taking attendance; if an "L" is not entered 
in the Period column the teacher may enter the student A or Absent Unexcused 
and a parent will get a notification to that effect. 
 

 

 

1.2.4   Entering Arrivals and Departures in the Office 

  
MyEdBC will only allow a single "daily" attendance record to be created for a single 
student.  If a student leaves or comes back to the school within a given day, it is entered 
as an Arrival or Departure and "appended" to the original entry.  For example, if a 
student arrives "late" in the morning and then leaves the school early for an 
appointment, it is entered into the same attendance record in the Class Office side tab: 
 

Attendance top tab > Class Office side tab >  = Attendance Activity 
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1. Click the Daily Code attendance entry for the correct 

student. 
2. Click Add below the Arrivals & Departures portion of the 

screen. 
3. Choose Departure from the Type drop down. 
4. Enter the time. 
5. Click the box beside "Is excused?". 
6. Click OK 

 
 
 
 
 
 

1.2.5   Entering Attendance for a "Group of students" using a Snapshot 

 
1. You can create attendance records for a group of students if they are going to be 

away en masse for a field trip, athletic event, etc.   
2. Go to Student top tab > Snapshot side tab, select and copy the "name" of your 

snapshot to your 
clipboard e.g. 
Volleyball Team.  
(If you haven't 
already created 
the snapshot, you 
must create it 
prior to assigning 
the attendance.) 

3. Click the 
Attendance top 
tab > Class 
Office side tab > 
Options > Multi-
Add Class 
Attendance 

4. Students to 
include = 
Snapshot 
 

5. Search value = "paste" the name of the snapshot here. (it must be exact) 
6. Select the correct date. 
7. Click the magnifying glass to enter the periods affected (AM, PM, or AM and 

PM). 
8. Attendance code – AUTH (for field trip) 
9. Click the magnifying glass to enter the Attendance Reason (field trip). 
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10. Uncheck Overwrite existing (checking this box will overwrite a previous 

attendance record for any student in the snapshot who has already been marked 

Absent for the day) 

1.2.6   Entering Class Attendance for Multiple Students at the Same Time 

 
 
School > Attendance > Class Office > Options > BC Multi-Add Class Attendance  
 

 Students to Include – select the students  
o Student IDs – opens the Student IDs entry box for entry of pupil numbers  

o Current Selection – uses the Current Selection of students on the Class Office 
Screen. Filter to the group of students needed  

o Start and End Dates – defaults to the current date, enter the correct date 
or range of dates for the attendance record entry  

 Select period(s) – select a single or multiple periods from the picklist  

 Attendance code – The code determines the type of Daily Attendance record 
created, select the appropriate code for  

o A – Absent  

o AE – Absent Excused  

o L - Late  
LE – Late Excused  

o AUTH – Authorized (this is the code used for Field Trips) 

o D – Early Dismissal  

 Time In - available for entry when Attendance code of L - Late or LE - Late 
Excused is selected. Time can be entered as a numeric and will be automatically 
formatted on the student record - HH:MM AM/PM. (10:15 AM)  

 Time Out – available for entry when Attendance code of D – Early Dismissal is 
selected. Time can be entered as a numeric and will be automatically formatted on 
the student record - HH:MM AM/PM. (10:15 AM)  

 Attendance Reason – select the appropriate Attendance Reason from the picklist 
per school or district policy  

 Duplicated Records - provides options for how the system handles a record if one 
already exists for a student on that date.  

o Skip – will not overwrite the existing class attendance record  

o Replace – will overwrite the existing class attendance record with the new 
information  
 

Ensure you have only the records you want to add Attendance information for, selected 

and showing on the screen BEFORE you proceed! 
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Click Run to record these absences. A confirmation pop-up will appear indicating 
how many records were updated. 

 

 

 

1.2.7   Entering Paper Based (TOC) Attendance 

 

The quickest and most efficient method of recording paper-based attendance by Class 

is by changing to the Staff View (or "teacher" view) and adding attendance entries for 

the course or course section in the Class List. 

Staff View > Select Teacher > Classes Meeting > Attendance 
 
In Staff view attendance is accessed through the Today’s Classes widget or the 
Attendance top tab. 

VERY IMPORTANT: 

When creating attendance records/entries for multiple students using the 

 under Options in the Class Office side tab, it is 

imperative that ONLY the students you are creating an attendance record for 

are displayed on the screen either through: 

 Snapshot  

 Section 

 Selection (and then choosing Options > Show Selected) 

If you do not refine the selection to display only the students you want, you 

run the risk of creating an attendance record for ALL STUDENTS in your 

school.  If you forget, the only way to reverse this error is to go into every 

period entry for every student and click DELETE.  (e.g. If you make this error 

and you have 800 students in your school, and 4 periods per day then you 

will have to delete 3200 entries manually!) 
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Class Attendance is taken for all course sections by selecting the corresponding button 
(A or L in the screenshot) on a given date and is posted to the student record using the 
Post button. No Daily Attendance value is created by the Staff view class posting in any 
course section.  
 

1.3 Attendance Codes 
 
Student Attendance codes indicate what type of Attendance Record is created for the 
student. These six system codes, combined with optional additional settings define the 
type of attendance record. A Reason code may be assigned to indicate why a student 
was given the attendance record per school or district policy.  

 A (Absent) – Absent Excused or Absent Unexcused  
o Excused – check the excused checkbox or use the A-E dropdown if available 
o Unexcused – leave the checkbox unchecked  

 L (Late) – Late Excused or Late Unexcused  
o Excused – check the Excused checkbox  
o Unexcused – leave the Excused checkbox unchecked  

 Time In – place to record the time the student arrived (per school or district policy) 
defaults to the current time, edit as appropriate 
 
 

 D (Dismissal) – Dismissal Excused and Dismissal Unexcused  
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o Excused – check the Excused checkbox  
o Unexcused – leave the Excused checkbox unchecked  
o Time Out – place to record the time the student left (per school or district 

policy) defaults to the current time, edit as appropriate  
 AUTH (Authorized) –  

o Absent? – determines if the AUTH code day is counted as an absence for 
the student in summary counts  

 Checked will count as an absence for the student  
 Unchecked will not count as an absence for the student  

 ISS (In School Suspension) – can be applied as a standard attendance entry and is 
automatically assigned as ISS – Excused to a student given an In School 
Suspension with a date range in the Conduct module. The record can be edited to 
uncheck the Excused checkbox per school or district policy. See the Conduct 
Management guide for details.  

 OSS (Out of School Suspension) can be applied as a standard attendance entry 
and is automatically assigned as OSS – Excused to a student given an Out of School 
Suspension with a date range in the Conduct module. The record can be edited to 
uncheck the Excused checkbox per school or district policy. See the Conduct 
Management guide for details.  

 

1.4 Attendance Reports 
 

1.4.1 Class Attendance Reports 

 
School view > Attendance top tab > Class Office side tab > Reports 
 

1.4.1.1   BC Class Attendance Call Sheet 

 Lists students with an Absent (unexcused) attendance record entered on that day, report 
includes: Name, Grade level, Homeroom, Gender, Attendance Code, and the Name and 
Phone numbers of the two student contacts with highest priority  

o Date 

o Sort results by – select Name, Grade Level or Homeroom from the dropdown list 
o Format – select the format to print 

 

1.4.1.2   BC Class Attendance Post Verification  

 Advises when and if Class Attendance was posted by a staff user on the selected date.  
The report can be run for a selected course section or for a selected teacher. 

o Start and End Dates - enter the range of dates to include on the report 
o Select class – select a course section from the picklist  

o Select teacher – select a teacher from the picklist 
o Show non-posts only 

 Check - to only show classes where attendance was not posted 

 Uncheck - to show all classes and if they were posted or not  

o Sort results by – Name or Time posted  

o Format – select the format to print  
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1.4.1.3   BC Class Attendance Post History 

 Provides a historical record of attendance postings by course section or by teacher. 
o Start and End Dates - enter the range of dates to include on the report 
o Select class – select a course section from the picklist  
o Select teacher – select a teacher from the picklist  
o Sort Results by – Date, Post Count or Period  
o Format – select the format to print  

 

1.4.1.4   BC Class List w. Grid 

 Lists students in a course section with fillable column headers in a grid format 
o Column Labels – enter the information to print in the Column Headers  
o Sections to include – select All or select a Term Code, Course Number, Section, 

Schedule Expression or Teacher.  
o Sort results by - select Course or Teacher  
o Format – select the format to print  
 

1.4.1.5   BC Principal’s Attendance by Class  

 Allows schools to review and analyze student Class attendance using a parameter form 
with multiple criteria. The tool will return a list of students that meet the specified 
threshold. If the criteria is to include Absences greater than or equal to 3, the report will 
include students that have 3 or more absences per section, but will return a complete 
listing of the student’s attendance in their other sections.  

o Start and End Dates – enter the range of dates to include on the report  
o Students to include – select All, Current Selection or select a YOG, Snapshot, 

Course Section, Combined Classes ID, Grade or Student Program  
o Criteria – enter and combine different criteria to build the report  

 Absence Code – use pre filled values or select a code from the 
dropdown  

 Reasons – select from the dropdown  
 Operator – select from the dropdown  
 Exclude Excused – check to exclude for each criteria line  
 Connector – select And or Or to combine criteria lines  

o Sort results by – Name, YOG or Homeroom  
o Group results by – Homeroom, House Code, Team Code  
o Format – select the format to print  

 

1.4.2  Daily Attendance Reports 
 

School view > Attendance top tab > Daily Office side tab > Reports 
 

1.4.2.1  BC Homeroom List w. Desig 

 Lists students in a Homeroom with their grade and birthdate and if they are a designated 
or aboriginal student 

o Students to include – select All or select a Homeroom or Grade.  
o Students to include – if you select Homeroom or Grade above, you have to type in just 

the homeroom number or just the grade you want 
o Check boxes -  deselect any that you DO NOT want to show on the report 
o Sort results by - select Usual Name or Grade  
o Format – select the format to print  

 



 Attendance – Class Office 
 

N:\Learning Technology Dept\Training & Support\MyEdBC\Attendance\Attendance - Class Office .docx 
12 

  

1.4.2.2   BC Homeroom List w. Grid 

 Lists students in a Homeroom with fillable column headers in a grid format 
o Column Labels – enter the information to print in the Column Headers  
o Students to include – select All or select a Homeroom or Grade.  
o Students to include – if you select Homeroom or Grade above, you have to type in just 

the homeroom number or just the grade you want 
o Sort results by - select Usual Name or Grade  
o Format – select the format to print  

 

1.4.3  Other Attendance Reports 

 
School view > Student top tab > select student > Attendance side tab > Reports 
     OR 
School view > Student top tab > select student(s) > Options > Show Selected > 
Reports 
 

1.4.3.1  BC Attendance History 

 Prints a list of student's attendance records for the date range chosen 
o School – defaults to primary school.  
o Start and End Dates – enter the range of dates to include on the report  
o Students to include – select All, YOG, Homeroom or Snapshot. 
o Students to include – if you select anything other than ALL, type in the 

information exactly 
o Check boxes -  deselect any that you DO NOT want to show on the 

report 
o Sort results by - select Name, YOG or Grade  
o Format – select the format to print  

 


